Unable to access exchange.parchment.com
Incident Report for Parchment
Resolved
This issue has been resolved.
Posted 3 months ago. May 04, 2018 - 13:55 PDT
Monitoring
We have resolved the issue preventing users from accessing exchange.parchment.com and are currently monitoring the site.
Posted 3 months ago. May 04, 2018 - 13:54 PDT
Identified
We have identified the issue and are working to restore the site.
Posted 3 months ago. May 04, 2018 - 13:20 PDT
Investigating
We are currently Investigating an issue with accessing exchange.parchment.com
Posted 3 months ago. May 04, 2018 - 13:10 PDT
This incident affected: Parchment 6 (Administrator (Login & Processing)) and Parchment 7 (Administrator (Login & Processing)).