Learner Support Training Today 9am MST / 11am Eastern
Incident Report for Parchment
Resolved
We were able to complete this mandatory training in less time than expected and all support services have now resumed. Thank you for your patience.
Posted Feb 06, 2024 - 09:21 PST
Identified
Today Feb 6, 2024 Parchment Learner Support team members will attend a mandatory training and orientation from 9am MST (11am Eastern) until 11 am MST (1pm Eastern)
During this time Learners can utilize our help center or contact support via web case at www.parchment.com/support for follow up
Phone support and live chat will be unavailable during this mandatory training
Posted Feb 06, 2024 - 06:50 PST
This incident affected: Supporting Services (Parchment Support).