Company Wide Meeting (2/1)
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Feb 01, 2024 - 14:34 PST
Identified
Administrative Phone Support will be temporarily unavailable from 2:45 PM CST - 4:00 PM CST today for a company meeting. We apologize for the inconvenience. We will respond to your inquiry as soon as possible.
Posted Feb 01, 2024 - 11:15 PST
This incident affected: Supporting Services (Parchment Support).