Potential Email Delays
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Feb 10, 2024 - 06:15 PST
Monitoring
This evening beginning at 6pm MST Parchment will be performing an email domain migration. There is the possibility for some emails sent to a parchment.com address to be returned undeliverable. Should this occur, please wait a few hours and then resend the message. We expect this work to be completed overnight.
Please note this can include emails sent to the following Parchment domains
@parchment.com
@needmytranscript.com
@scrip-safe.com
@digitary.net
Posted Feb 09, 2024 - 16:32 PST
This incident affected: Supporting Services (Parchment Support).