Parchment Closed Monday 2/19/2024
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Feb 23, 2024 - 13:02 PST
Identified
Parchment, including Parchment Support and Print + Mail Services, will be closed 2/19/2024. We look forward to assisting you again on Tuesday 2/20/2024.
Posted Feb 16, 2024 - 10:44 PST
This incident affected: Supporting Services (Parchment Print, Parchment Support).