Parchment Holiday Closures
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Jan 02, 2024 - 06:39 PST
Update
Parchment (including Parchment Support and Parchment Print + Mail) will be closed on the following days in observance of company holidays: December 22, December 25, December 29, January 1
Posted Dec 15, 2023 - 11:46 PST
Update
Parchment (including Parchment Support and Parchment Print + Mail) will be closed on the following days in observance of company holidays: December 22, December 25, December 29, January 1

In addition, Parchment Member Administrators may experience slight delays in Parchment Support responsiveness on December 12 & 13 as Parchment employees gather virtually for our traditional year-end company meetings and trainings. Learner Support and Print & Mail services will operate as usual.
Posted Nov 27, 2023 - 07:53 PST
Investigating
Parchment (including Parchment Support and Parchment Print + Mail) will be closed on the following days in observance of company holidays
Thursday, November 23 & Friday, November 24
December 22, December 25, December 29, January 1
Posted Nov 06, 2023 - 12:31 PST
This incident affected: Supporting Services (Parchment Print, Parchment Support).