Fulfillment Delays for Adobe Certified PDFs
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 11:40 PDT
Investigating
Our Engineering teams are currently investigating an issue that is impacting the fulfillment and delivery of Adobe Certified PDFs on our P6, P7 and Award platforms. You may notice orders in error and we will attempt work to resolve these soon after our services are restored.
Posted Mar 19, 2024 - 22:38 PDT
This incident affected: Consumer (Ordering) and Parchment Award - Transcript Services, Parchment Award - Diploma, Certificate, Badge, CLR.