Parchment Member Services Department Meeting (11/17/2023: 1:45 - 2:45 PM CST)
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Nov 17, 2023 - 12:30 PST
Identified
Administrative Phone Support will be temporarily unavailable from 1:45 PM CST - 2:45 PM CST today for a company meeting. We apologize for the inconvenience. We will respond to your inquiry as soon as possible.
Posted Nov 17, 2023 - 10:02 PST
This incident affected: Supporting Services (Parchment Support).