Document preview on Parchment 7 TODO list
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted 13 days ago. Sep 12, 2017 - 17:48 PDT
Identified
Our engineering team has identified the issue and have developed a resolution. We are working through our testing and validation processes.  Current estimate to complete and release is Tuesday 9/12 during our normal release process at 5pm EDT.
Posted 17 days ago. Sep 08, 2017 - 13:56 PDT
Update
Our engineers are continuing to dig into this issue. We will provide updates when we have more information.
Posted 17 days ago. Sep 08, 2017 - 09:05 PDT
Update
We are seeing this behavior sporadically in Firefox an IE as well. Our team is working hard to develop a fix.
Posted 17 days ago. Sep 07, 2017 - 23:08 PDT
Investigating
We are currently investigating an issue with the document preview on the Send admin TODO list. The issue only appears to be impacting Chrome and Safari users. We have not observed it with IE or Firefox browsers.
Posted 17 days ago. Sep 07, 2017 - 18:21 PDT
This incident affected: Parchment 7 (Administrator (Login & Processing)).