Parchment Upcoming Closure on Monday January 15, 2024
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Jan 16, 2024 - 10:19 PST
Monitoring
Parchment will be closed Monday, January 15, 2024 in observance of Dr. Martin Luther King, Jr. Day. There will be no transcripts or diplomas mailed on this day, and support will be unavailable. We will reopen on Tuesday, January 16th.
Posted Jan 08, 2024 - 08:20 PST