Parchment Learner Support Web Case Submission Outage
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Feb 26, 2024 - 14:19 PST
Investigating
We are currently investigating an issue related to the web case submission form at www.parchment.com/support
Learners in need of support can still visit www.parchment.com/chat-support to access phone and chat as well as the self-service help center articles.
Posted Feb 23, 2024 - 15:51 PST
This incident affected: Supporting Services (Salesforce / Parchment Help Center).