Unable to place an order on Parchment.com
Incident Report for Parchment
Resolved
We have resolved the error preventing learners from placing orders on Parchment.com and the system is now restored to its normal state.
Posted 6 months ago. May 15, 2018 - 15:49 PDT
Investigating
We are currently investigating an error when trying to place an order on Parchment.com
Posted 6 months ago. May 15, 2018 - 14:52 PDT
This incident affected: Consumer (Learner (Login, Registration & Ordering)), Integrations (SPEEDE Integration, SFTP Downloads, SFTP Services (Outbound/Inbound)), and Parchment 7 (Learner (Login, Registration & Ordering)).