Error while registering for an account on the Storefront
Incident Report for Parchment
Resolved
We have resolved the issue with students receiving an error message while registering.
Posted 4 months ago. Apr 09, 2018 - 12:10 PDT
Investigating
We are currently aware of an issue that may impact students when registering for an account. We are investigating now and taking steps to resolve. We will provide an update once it becomes available.
Posted 4 months ago. Apr 09, 2018 - 08:56 PDT
This incident affected: Consumer (Learner (Login, Registration & Ordering)).