Delayed processing for Parchment Award
Incident Report for Parchment
Resolved
This incident has been resolved and all Award orders are processing.
Posted Aug 07, 2018 - 12:52 PDT
Investigating
We are currently investigating reports of processing delays for Parchment Award users.
Posted Aug 07, 2018 - 10:55 PDT
This incident affected: Parchment Award - Diploma, Certificate, Badge, CLR.