Delays in processing orders
Incident Report for Parchment
Resolved
We have resolved the issue that was causing the delay in processing.
Posted 9 days ago. May 14, 2018 - 09:15 PDT
Monitoring
We were experiencing delays earlier with the processing of orders, but all systems are now operating normally.
Posted 9 days ago. May 14, 2018 - 08:21 PDT
This incident affected: Parchment 6 (Administrator (Login & Processing)) and Parchment 7 (Administrator (Login & Processing)).